Eventic
Search…
Server requirements
What configuration do I need to install Eventic?
mod_write should be enabled in your server, otherwise, a 404 error will be thrown once you visit a page other than the homepage, like /installer (the setup wizard) for instance

PHP Version

  • PHP 7.1.3 or higher
Database
  • MySql 5.6 or higher

Extensions

  • Ctype
  • iconv
  • JSON
  • PCRE
  • Session
  • SimpleXML
  • Tokenizer
  • intl
  • OpenSSL
  • DOM
  • mbstring
  • curl
  • fileinfo
  • gd
  • libXML
  • XML
  • XMLReader
  • XMLWriter
  • Zip
  • ZLib
Most of the previous extensions are enabled by default

Writable Directories and Folders

  • /var/cache/
  • /var/log/
  • /public/media/
  • /public/uploads/
  • /sessions/
  • /assets/js/translations/
  • .env
The above directories must be already created and writable (775 permission).
The Setup Wizard will check your server configuration automatically
Copy link
On this page
PHP Version
Extensions
Writable Directories and Folders